<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Bossier City Mayor Lo Walker to run for a fifth term | Bossier Press-Tribune</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://bossierpress.com/xmlrpc.php" />
    <meta property="og:image" content="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Bossier Press-Tribune &raquo; Feed" href="http://bossierpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bossier Press-Tribune &raquo; Comments Feed" href="http://bossierpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bossier Press-Tribune &raquo; Bossier City Mayor Lo Walker to run for a fifth term Comments Feed" href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/bossierpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://bossierpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='http://bossierpress.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='http://bossierpress.com/wp-content/themes/Newsmag/simple-staff-list-custom.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='nm_mailchimp-styles-css'  href='http://bossierpress.com/wp-content/plugins/nmedia-mailchimp-widget//plugin.styles.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;ver=4.5' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://bossierpress.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://bossierpress.com/wp-content/themes/Newsmag/style.css?ver=4.5' type='text/css' media='all' />
<script type='text/javascript' src='http://bossierpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://bossierpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://bossierpress.com/wp-content/plugins/itro-popup/scripts/itro-scripts.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var nm_mailchimp_vars = {"ajaxurl":"http:\/\/bossierpress.com\/wp-admin\/admin-ajax.php","plugin_url":"http:\/\/bossierpress.com\/wp-content\/plugins\/nmedia-mailchimp-widget\/","plugin_doing":"http:\/\/bossierpress.com\/wp-content\/plugins\/nmedia-mailchimp-widget\/images\/loading.gif","settings":{"action":"nm_mailchimp_save_settings","nm_mailchimp_mc_api_key":"0fcb2423f2cea9b36530b483c2f1f8ba-us6","nm_mailchimp_button_title":"","nm_mailchimp_ok_message":"","nm_mailchimp_form_redirect":"","nm_mailchimp_modal_title":"","nm_mailchimp_modal_content":"","nm_mailchimp_modal_size":"","nm_mailchimp_form_css":"","nm_mailchimp_form_saved":""},"messages":{"error_subscription":"Please try with different email"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://bossierpress.com/wp-content/plugins/nmedia-mailchimp-widget//js/script.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='http://bossierpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://bossierpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://bossierpress.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='High school football: Bossier Parish offensive stat leaders through Week 7' href='http://bossierpress.com/high-school-football-bossier-parish-offensive-stat-leaders-through-week-7/' />
<link rel='next' title='Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening' href='http://bossierpress.com/tennis-bossier-tennis-center-pro-killen-to-compete-in-exhibition-wednesday-evening/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel="canonical" href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/" />
<link rel='shortlink' href='http://bossierpress.com/?p=82283' />
<link rel="alternate" type="application/json+oembed" href="http://bossierpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://bossierpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="http://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://bossierpress.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta property="og:type" content="article" />
<meta property="og:url" content="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/" />
<meta property="og:title" content="Bossier City Mayor Lo Walker to run for a fifth term" />
<meta property="og:site_name" content="Bossier Press-Tribune" />
<meta property="og:locale" content="en_US" />
<meta property="og:description" content="Bossier City Mayor Lorenz “Lo” Walker will seek office for a record fifth term. Mayor Walker confirmed his plans to the Press-Tribune Tuesday afternoon. “I didn’t want to say anything to step on the election going on across the river in Shreveport..." />
<meta property="og:image" content="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker-150x150.jpg" />

<!-- JS generated by theme -->

<script>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</script>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://bossierpress.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://bossierpress.com/category/news/",
                                "name": "News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://bossierpress.com/category/news/local/",
                                "name": "Local"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/",
                                "name": "Bossier City Mayor Lo Walker to run for a fifth term"                                
                            }
                        }    ]
                        }
                       </script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-82283 single-format-standard bossier-city-mayor-lo-walker-to-run-for-a-fifth-term global-block-template-1 wpb-js-composer js-comp-ver-5.5.5 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-11079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-11079"><a href="http://bossierpress.com/">Home</a></li>
<li id="menu-item-13834" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-13834"><a href="http://bossierpress.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://bossierpress.com/category/news/local/">Local</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/news/national/">National</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/news/state/">State</a></li>
</ul>
</li>
<li id="menu-item-13838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13838"><a href="http://bossierpress.com/category/sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://bossierpress.com/category/sports/college/">College</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/sports/league/">League</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/sports/leisure/">Leisure</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/sports/middle-school/">Middle School</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/sports/prep/">Prep</a></li>
</ul>
</li>
<li id="menu-item-13839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-children menu-item-13839"><a href="http://bossierpress.com/category/life/">Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://bossierpress.com/category/life/arts/">Arts</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/life/at-home/">At Home</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/life/community/">Community</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/life/engagementsweddingsanniversaries/">Engagements/Weddings/Anniversaries</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/life/history/">History</a></li>
	<li id="menu-item-13841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13841"><a href="http://bossierpress.com/category/life/obituaries/">Obituaries</a></li>
</ul>
</li>
<li id="menu-item-13840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13840"><a href="http://bossierpress.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://bossierpress.com/category/opinion/letters/">Letters</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/opinion/other-opinion/">Other Opinion</a></li>
	<li class="menu-item-0"><a href="http://bossierpress.com/category/opinion/our-opinion/">Our Opinion</a></li>
</ul>
</li>
<li id="menu-item-64478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64478"><a href="http://bossierpress.com/subscribe/">Subscribe</a></li>
<li id="menu-item-1815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1815"><a href="http://bossierpress.com/classifieds/">Classifieds<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-1803" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1803"><a href="http://bossierpress.com/publicnotice/">Public Notices</a></li>
</ul>
</li>
<li id="menu-item-24714" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-24714"><a href="http://bossierpress.com/contact/">Contact Us<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-76796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76796"><a href="http://bossierpress.com/privacy-policy-3/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://bossierpress.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap">
    
        <div class="td-outer-container">
        
            <!--
Header style 1
-->

<div class="td-header-container td-header-wrap td-header-style-1">
    <div class="td-header-row td-header-top-menu">
        
    <div class="td-top-bar-container top-bar-style-1">
        <div class="td-header-sp-top-menu">

    </div>            </div>

<!-- LOGIN MODAL -->
    </div>

    <div class="td-header-row td-header-header">
        <div class="td-header-sp-logo">
                    <a class="td-main-logo" href="http://bossierpress.com/">
            <img class="td-retina-data" data-retina="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogoRetina.png" src="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogo.png" alt=""/>
            <span class="td-visual-hidden">Bossier Press-Tribune</span>
        </a>
            </div>
        <div class="td-header-sp-rec">
            
<div class="td-header-ad-wrap  td-ad-m td-ad-tp td-ad-p">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_5bc8dfc0c60e3_rand td_block_template_1">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-3723760168360823" data-ad-slot="3767824597"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-3723760168360823" data-ad-slot="3767824597"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-3723760168360823" data-ad-slot="3767824597"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 



</div>        </div>
    </div>

    <div class="td-header-menu-wrap">
        <div class="td-header-row td-header-border td-header-main-menu">
            <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            <a  class="td-main-logo" href="http://bossierpress.com/">
        <img class="td-retina-data" data-retina="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogoRetina.png" src="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogo.png" alt=""/>
    </a>
        </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-11079"><a href="http://bossierpress.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-13834"><a href="http://bossierpress.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_2_5bc8dfc0c6b48 = new tdBlock();
block_td_uid_2_5bc8dfc0c6b48.id = "td_uid_2_5bc8dfc0c6b48";
block_td_uid_2_5bc8dfc0c6b48.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"26","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5bc8dfc0c6b48_rand","tdc_css_class":"td_uid_2_5bc8dfc0c6b48_rand","tdc_css_class_style":"td_uid_2_5bc8dfc0c6b48_rand_style"}';
block_td_uid_2_5bc8dfc0c6b48.td_column_number = "3";
block_td_uid_2_5bc8dfc0c6b48.block_type = "td_block_mega_menu";
block_td_uid_2_5bc8dfc0c6b48.post_count = "5";
block_td_uid_2_5bc8dfc0c6b48.found_posts = "4663";
block_td_uid_2_5bc8dfc0c6b48.header_color = "";
block_td_uid_2_5bc8dfc0c6b48.ajax_pagination_infinite_stop = "";
block_td_uid_2_5bc8dfc0c6b48.max_num_pages = "933";
tdBlocksArray.push(block_td_uid_2_5bc8dfc0c6b48);
</script><div class="td_block_wrap td_block_mega_menu td_uid_2_5bc8dfc0c6b48_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_2_5bc8dfc0c6b48" ><div id=td_uid_2_5bc8dfc0c6b48 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" class="td-image-wrap" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service">Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" class="td-image-wrap" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"><img width="180" height="94" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 180w, http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting">UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" class="td-image-wrap" title="Benton teacher arrested for video voyeruism"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Benton teacher arrested for video voyeruism"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" title="Benton teacher arrested for video voyeruism">Benton teacher arrested for video voyeruism</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/community-celebrates-opening-of-i-49-at-i-220/" rel="bookmark" class="td-image-wrap" title="Community celebrates opening of I-49 at I-220"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Photo-Oct-17-10-15-35-AM-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Photo-Oct-17-10-15-35-AM-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/Photo-Oct-17-10-15-35-AM-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Community celebrates opening of I-49 at I-220"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/community-celebrates-opening-of-i-49-at-i-220/" rel="bookmark" title="Community celebrates opening of I-49 at I-220">Community celebrates opening of I-49 at I-220</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/bossier-city-to-make-60-million-in-upgrades/" rel="bookmark" class="td-image-wrap" title="Bossier City to make $60 million in upgrades"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/tinsley-sign-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/tinsley-sign-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/tinsley-sign-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Bossier City to make $60 million in upgrades"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/bossier-city-to-make-60-million-in-upgrades/" rel="bookmark" title="Bossier City to make $60 million in upgrades">Bossier City to make $60 million in upgrades</a></h3>            </div>
        </div>
        </div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_2_5bc8dfc0c6b48" id="td_uid_3_5bc8dfc0c7c4a" data-td_block_id="td_uid_2_5bc8dfc0c6b48" data-td_filter_value="" href="http://bossierpress.com/category/news/">All</a><a class="mega-menu-sub-cat-td_uid_2_5bc8dfc0c6b48"  id="td_uid_4_5bc8dfc0c7caf" data-td_block_id="td_uid_2_5bc8dfc0c6b48" data-td_filter_value="31" href="http://bossierpress.com/category/news/local/">Local</a><a class="mega-menu-sub-cat-td_uid_2_5bc8dfc0c6b48"  id="td_uid_5_5bc8dfc0c7d14" data-td_block_id="td_uid_2_5bc8dfc0c6b48" data-td_filter_value="29" href="http://bossierpress.com/category/news/national/">National</a><a class="mega-menu-sub-cat-td_uid_2_5bc8dfc0c6b48"  id="td_uid_6_5bc8dfc0c7d75" data-td_block_id="td_uid_2_5bc8dfc0c6b48" data-td_filter_value="30" href="http://bossierpress.com/category/news/state/">State</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5bc8dfc0c6b48" data-td_block_id="td_uid_2_5bc8dfc0c6b48"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5bc8dfc0c6b48" data-td_block_id="td_uid_2_5bc8dfc0c6b48"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-13838"><a href="http://bossierpress.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_7_5bc8dfc0c9e0b = new tdBlock();
block_td_uid_7_5bc8dfc0c9e0b.id = "td_uid_7_5bc8dfc0c9e0b";
block_td_uid_7_5bc8dfc0c9e0b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"43","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_7_5bc8dfc0c9e0b_rand","tdc_css_class":"td_uid_7_5bc8dfc0c9e0b_rand","tdc_css_class_style":"td_uid_7_5bc8dfc0c9e0b_rand_style"}';
block_td_uid_7_5bc8dfc0c9e0b.td_column_number = "3";
block_td_uid_7_5bc8dfc0c9e0b.block_type = "td_block_mega_menu";
block_td_uid_7_5bc8dfc0c9e0b.post_count = "5";
block_td_uid_7_5bc8dfc0c9e0b.found_posts = "4008";
block_td_uid_7_5bc8dfc0c9e0b.header_color = "";
block_td_uid_7_5bc8dfc0c9e0b.ajax_pagination_infinite_stop = "";
block_td_uid_7_5bc8dfc0c9e0b.max_num_pages = "802";
tdBlocksArray.push(block_td_uid_7_5bc8dfc0c9e0b);
</script><div class="td_block_wrap td_block_mega_menu td_uid_7_5bc8dfc0c9e0b_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_7_5bc8dfc0c9e0b" ><div id=td_uid_7_5bc8dfc0c9e0b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/high-school-football-this-weeks-schedule/" rel="bookmark" class="td-image-wrap" title="High school football: This week&#8217;s schedule"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/rs1-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/rs1-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/rs1-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="High school football: This week&#8217;s schedule"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/high-school-football-this-weeks-schedule/" rel="bookmark" title="High school football: This week&#8217;s schedule">High school football: This week&#8217;s schedule</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/mens-college-basketball-bpccs-eric-parrish-commits-to-nevada/" rel="bookmark" class="td-image-wrap" title="Men&#8217;s college basketball: BPCC&#8217;s Eric Parrish commits to Nevada"><img width="180" height="113" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/07/BPCC-logo-800x-x-500.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/07/BPCC-logo-800x-x-500.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/07/BPCC-logo-800x-x-500.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Men&#8217;s college basketball: BPCC&#8217;s Eric Parrish commits to Nevada"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/mens-college-basketball-bpccs-eric-parrish-commits-to-nevada/" rel="bookmark" title="Men&#8217;s college basketball: BPCC&#8217;s Eric Parrish commits to Nevada">Men&#8217;s college basketball: BPCC&#8217;s Eric Parrish commits to Nevada</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/tennis-bossier-tennis-center-pro-killen-to-compete-in-exhibition-wednesday-evening/" rel="bookmark" class="td-image-wrap" title="Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/killen-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/killen-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/killen-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/tennis-bossier-tennis-center-pro-killen-to-compete-in-exhibition-wednesday-evening/" rel="bookmark" title="Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening">Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/high-school-football-bossier-parish-offensive-stat-leaders-through-week-7/" rel="bookmark" class="td-image-wrap" title="High school football: Bossier Parish offensive stat leaders through Week 7"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/h13-2-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/h13-2-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/h13-2-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="High school football: Bossier Parish offensive stat leaders through Week 7"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/high-school-football-bossier-parish-offensive-stat-leaders-through-week-7/" rel="bookmark" title="High school football: Bossier Parish offensive stat leaders through Week 7">High school football: Bossier Parish offensive stat leaders through Week 7</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/photo-gallery-lsu-vs-georgia/" rel="bookmark" class="td-image-wrap" title="Photo gallery: LSU vs. Georgia"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/lsu12-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/lsu12-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/lsu12-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Photo gallery: LSU vs. Georgia"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/photo-gallery-lsu-vs-georgia/" rel="bookmark" title="Photo gallery: LSU vs. Georgia">Photo gallery: LSU vs. Georgia</a></h3>            </div>
        </div>
        </div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b" id="td_uid_8_5bc8dfc0cb35f" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="" href="http://bossierpress.com/category/sports/">All</a><a class="mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b"  id="td_uid_9_5bc8dfc0cb3c4" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="46" href="http://bossierpress.com/category/sports/college/">College</a><a class="mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b"  id="td_uid_10_5bc8dfc0cb42c" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="44" href="http://bossierpress.com/category/sports/league/">League</a><a class="mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b"  id="td_uid_11_5bc8dfc0cb48c" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="49" href="http://bossierpress.com/category/sports/leisure/">Leisure</a><a class="mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b"  id="td_uid_12_5bc8dfc0cb4eb" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="48" href="http://bossierpress.com/category/sports/middle-school/">Middle School</a><a class="mega-menu-sub-cat-td_uid_7_5bc8dfc0c9e0b"  id="td_uid_13_5bc8dfc0cb54a" data-td_block_id="td_uid_7_5bc8dfc0c9e0b" data-td_filter_value="47" href="http://bossierpress.com/category/sports/prep/">Prep</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_5bc8dfc0c9e0b" data-td_block_id="td_uid_7_5bc8dfc0c9e0b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_5bc8dfc0c9e0b" data-td_block_id="td_uid_7_5bc8dfc0c9e0b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-13839"><a href="http://bossierpress.com/category/life/">Life</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_14_5bc8dfc0cd5f8 = new tdBlock();
block_td_uid_14_5bc8dfc0cd5f8.id = "td_uid_14_5bc8dfc0cd5f8";
block_td_uid_14_5bc8dfc0cd5f8.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"32","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_14_5bc8dfc0cd5f8_rand","tdc_css_class":"td_uid_14_5bc8dfc0cd5f8_rand","tdc_css_class_style":"td_uid_14_5bc8dfc0cd5f8_rand_style"}';
block_td_uid_14_5bc8dfc0cd5f8.td_column_number = "3";
block_td_uid_14_5bc8dfc0cd5f8.block_type = "td_block_mega_menu";
block_td_uid_14_5bc8dfc0cd5f8.post_count = "5";
block_td_uid_14_5bc8dfc0cd5f8.found_posts = "3103";
block_td_uid_14_5bc8dfc0cd5f8.header_color = "";
block_td_uid_14_5bc8dfc0cd5f8.ajax_pagination_infinite_stop = "";
block_td_uid_14_5bc8dfc0cd5f8.max_num_pages = "621";
tdBlocksArray.push(block_td_uid_14_5bc8dfc0cd5f8);
</script><div class="td_block_wrap td_block_mega_menu td_uid_14_5bc8dfc0cd5f8_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_14_5bc8dfc0cd5f8" ><div id=td_uid_14_5bc8dfc0cd5f8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/gallery-princeton-high-school-reunion/" rel="bookmark" class="td-image-wrap" title="Gallery: Princeton High School reunion"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/IMG_2478-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/IMG_2478-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/IMG_2478-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Gallery: Princeton High School reunion"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/gallery-princeton-high-school-reunion/" rel="bookmark" title="Gallery: Princeton High School reunion">Gallery: Princeton High School reunion</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/obituary-olivia-setzer-stephens/" rel="bookmark" class="td-image-wrap" title="Obituary &#8211; Olivia Setzer Stephens"><img width="180" height="93" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-1-BPT-Obits.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-1-BPT-Obits.jpg 180w, http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-1-BPT-Obits.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Obituary &#8211; Olivia Setzer Stephens"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/obituary-olivia-setzer-stephens/" rel="bookmark" title="Obituary &#8211; Olivia Setzer Stephens">Obituary &#8211; Olivia Setzer Stephens</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/obituary-billy-r-martin/" rel="bookmark" class="td-image-wrap" title="Obituary &#8211; Billy R. Martin"><img width="180" height="102" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 180w, http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Obituary &#8211; Billy R. Martin"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/obituary-billy-r-martin/" rel="bookmark" title="Obituary &#8211; Billy R. Martin">Obituary &#8211; Billy R. Martin</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/obituary-robert-stumon/" rel="bookmark" class="td-image-wrap" title="Obituary &#8211; Robert Stumon"><img width="180" height="102" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 180w, http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Obituary &#8211; Robert Stumon"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/obituary-robert-stumon/" rel="bookmark" title="Obituary &#8211; Robert Stumon">Obituary &#8211; Robert Stumon</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/obituary-david-ronald-crowe/" rel="bookmark" class="td-image-wrap" title="Obituary &#8211; David Ronald Crowe"><img width="180" height="102" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 180w, http://bossierpress.com/wp-content/uploads/2016/01/Featured-Image-2-BPT-Obits.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Obituary &#8211; David Ronald Crowe"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/obituary-david-ronald-crowe/" rel="bookmark" title="Obituary &#8211; David Ronald Crowe">Obituary &#8211; David Ronald Crowe</a></h3>            </div>
        </div>
        </div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8" id="td_uid_15_5bc8dfc0ce698" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="" href="http://bossierpress.com/category/life/">All</a><a class="mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8"  id="td_uid_16_5bc8dfc0ce6fd" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="37" href="http://bossierpress.com/category/life/arts/">Arts</a><a class="mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8"  id="td_uid_17_5bc8dfc0ce76a" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="59" href="http://bossierpress.com/category/life/at-home/">At Home</a><a class="mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8"  id="td_uid_18_5bc8dfc0ce7ce" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="36" href="http://bossierpress.com/category/life/community/">Community</a><a class="mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8"  id="td_uid_19_5bc8dfc0ce82d" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="58" href="http://bossierpress.com/category/life/engagementsweddingsanniversaries/">Engagements/Weddings/Anniversaries</a><a class="mega-menu-sub-cat-td_uid_14_5bc8dfc0cd5f8"  id="td_uid_20_5bc8dfc0ce88b" data-td_block_id="td_uid_14_5bc8dfc0cd5f8" data-td_filter_value="34" href="http://bossierpress.com/category/life/history/">History</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5bc8dfc0cd5f8" data-td_block_id="td_uid_14_5bc8dfc0cd5f8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_5bc8dfc0cd5f8" data-td_block_id="td_uid_14_5bc8dfc0cd5f8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13841"><a href="http://bossierpress.com/category/life/obituaries/">Obituaries</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-13840"><a href="http://bossierpress.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_21_5bc8dfc0cfe86 = new tdBlock();
block_td_uid_21_5bc8dfc0cfe86.id = "td_uid_21_5bc8dfc0cfe86";
block_td_uid_21_5bc8dfc0cfe86.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"38","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_21_5bc8dfc0cfe86_rand","tdc_css_class":"td_uid_21_5bc8dfc0cfe86_rand","tdc_css_class_style":"td_uid_21_5bc8dfc0cfe86_rand_style"}';
block_td_uid_21_5bc8dfc0cfe86.td_column_number = "3";
block_td_uid_21_5bc8dfc0cfe86.block_type = "td_block_mega_menu";
block_td_uid_21_5bc8dfc0cfe86.post_count = "5";
block_td_uid_21_5bc8dfc0cfe86.found_posts = "817";
block_td_uid_21_5bc8dfc0cfe86.header_color = "";
block_td_uid_21_5bc8dfc0cfe86.ajax_pagination_infinite_stop = "";
block_td_uid_21_5bc8dfc0cfe86.max_num_pages = "164";
tdBlocksArray.push(block_td_uid_21_5bc8dfc0cfe86);
</script><div class="td_block_wrap td_block_mega_menu td_uid_21_5bc8dfc0cfe86_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_21_5bc8dfc0cfe86" ><div id=td_uid_21_5bc8dfc0cfe86 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/white-louisiana-education-plan-provides-more-and-better-info-to-families-educators/" rel="bookmark" class="td-image-wrap" title="White: Louisiana Education Plan provides more and better info to families, educators"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/john-white-rsd-horizontaljpg-f3c602815949fbf7-180x135.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/john-white-rsd-horizontaljpg-f3c602815949fbf7-180x135.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/10/john-white-rsd-horizontaljpg-f3c602815949fbf7-360x270.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="White: Louisiana Education Plan provides more and better info to families, educators"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/white-louisiana-education-plan-provides-more-and-better-info-to-families-educators/" rel="bookmark" title="White: Louisiana Education Plan provides more and better info to families, educators">White: Louisiana Education Plan provides more and better info to families, educators</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/opinion-reviving-the-city-tennis-tournament-a-great-idea/" rel="bookmark" class="td-image-wrap" title="Opinion: Reviving The City tennis tournament a great idea"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/themes/Newsmag/images/no-thumb/td_180x135.png" alt=""/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/opinion-reviving-the-city-tennis-tournament-a-great-idea/" rel="bookmark" title="Opinion: Reviving The City tennis tournament a great idea">Opinion: Reviving The City tennis tournament a great idea</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/johnson-tax-reform-means-help-for-families/" rel="bookmark" class="td-image-wrap" title="Johnson: Tax reform means help for families"><img width="180" height="135" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2017/01/taxes.jpg" srcset="http://bossierpress.com/wp-content/uploads/2017/01/taxes.jpg 180w, http://bossierpress.com/wp-content/uploads/2017/01/taxes.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Johnson: Tax reform means help for families"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/johnson-tax-reform-means-help-for-families/" rel="bookmark" title="Johnson: Tax reform means help for families">Johnson: Tax reform means help for families</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/mayor-walker-writes-letter-in-support-of-swepco-wind-catcher-project/" rel="bookmark" class="td-image-wrap" title="Mayor Walker writes letter in support of SWEPCO Wind Catcher project"><img width="180" height="120" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/05/SWEPCO-Wind-Catcher-map.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/05/SWEPCO-Wind-Catcher-map.jpg 180w, http://bossierpress.com/wp-content/uploads/2018/05/SWEPCO-Wind-Catcher-map.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Mayor Walker writes letter in support of SWEPCO Wind Catcher project"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/mayor-walker-writes-letter-in-support-of-swepco-wind-catcher-project/" rel="bookmark" title="Mayor Walker writes letter in support of SWEPCO Wind Catcher project">Mayor Walker writes letter in support of SWEPCO Wind Catcher project</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/congressman-johnson-leading-religious-freedom-defenders-issue-letter-on-sb-512/" rel="bookmark" class="td-image-wrap" title="Congressman Johnson, leading religious freedom defenders issue letter on SB 512"><img width="180" height="133" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2014/05/Louisiana_State_Capitol_Baton_Rouge.jpg" srcset="http://bossierpress.com/wp-content/uploads/2014/05/Louisiana_State_Capitol_Baton_Rouge.jpg 180w, http://bossierpress.com/wp-content/uploads/2014/05/Louisiana_State_Capitol_Baton_Rouge.jpg 360w" sizes="(-webkit-min-device-pixel-ratio: 2) 360px, (min-resolution: 192dpi) 360px, 180px" alt="" title="Congressman Johnson, leading religious freedom defenders issue letter on SB 512"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/congressman-johnson-leading-religious-freedom-defenders-issue-letter-on-sb-512/" rel="bookmark" title="Congressman Johnson, leading religious freedom defenders issue letter on SB 512">Congressman Johnson, leading religious freedom defenders issue letter on SB 512</a></h3>            </div>
        </div>
        </div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_21_5bc8dfc0cfe86" id="td_uid_22_5bc8dfc0d1060" data-td_block_id="td_uid_21_5bc8dfc0cfe86" data-td_filter_value="" href="http://bossierpress.com/category/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_21_5bc8dfc0cfe86"  id="td_uid_23_5bc8dfc0d10d4" data-td_block_id="td_uid_21_5bc8dfc0cfe86" data-td_filter_value="39" href="http://bossierpress.com/category/opinion/letters/">Letters</a><a class="mega-menu-sub-cat-td_uid_21_5bc8dfc0cfe86"  id="td_uid_24_5bc8dfc0d1153" data-td_block_id="td_uid_21_5bc8dfc0cfe86" data-td_filter_value="40" href="http://bossierpress.com/category/opinion/other-opinion/">Other Opinion</a><a class="mega-menu-sub-cat-td_uid_21_5bc8dfc0cfe86"  id="td_uid_25_5bc8dfc0d11b7" data-td_block_id="td_uid_21_5bc8dfc0cfe86" data-td_filter_value="41" href="http://bossierpress.com/category/opinion/our-opinion/">Our Opinion</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5bc8dfc0cfe86" data-td_block_id="td_uid_21_5bc8dfc0cfe86"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5bc8dfc0cfe86" data-td_block_id="td_uid_21_5bc8dfc0cfe86"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-64478"><a href="http://bossierpress.com/subscribe/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-1815"><a href="http://bossierpress.com/classifieds/">Classifieds</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1803"><a href="http://bossierpress.com/publicnotice/">Public Notices</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-24714"><a href="http://bossierpress.com/contact/">Contact Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-76796"><a href="http://bossierpress.com/privacy-policy-3/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>

<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://bossierpress.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>        </div>
    </div>
</div>
    <div class="td-container td-post-template-default">
        <div class="td-container-border">
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    

    <article id="post-82283" class="post-82283 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-local category-news" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header td-pb-padding-side">
            <div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://bossierpress.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="http://bossierpress.com/category/news/">News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local" class="entry-crumb" href="http://bossierpress.com/category/news/local/">Local</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Bossier City Mayor Lo Walker to run for a fifth term</span></div>
            <ul class="td-category"><li class="entry-category"><a  href="http://bossierpress.com/category/news/">News</a></li><li class="entry-category"><a  href="http://bossierpress.com/category/news/local/">Local</a></li></ul>
            <header>
                <h1 class="entry-title">Bossier City Mayor Lo Walker to run for a fifth term</h1>

                

                <div class="meta-info">

                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://bossierpress.com/author/sgreen/">Sean Green</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-16T15:57:28+00:00" >October 16, 2018</time></span>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-82283">1025</span></div>                    <div class="td-post-comments"><a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comments"><i class="td-icon-comments"></i>8</a></div>                </div>
            </header>


        </div>

        <div class="td-post-sharing-top td-pb-padding-side"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Bossier+City+Mayor+Lo+Walker+to+run+for+a+fifth+term&url=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F&via=Bossier+Press-Tribune">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/&amp;media=http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg&description=Bossier+City+Mayor+Lo+Walker+to+run+for+a+fifth+term">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Bossier City Mayor Lo Walker to run for a fifth term %0A%0A http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content td-pb-padding-side">

        <div class="td-post-featured-image"><a href="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg" data-caption=""><img width="1859" height="2048" class="entry-thumb td-modal-image" src="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg 1859w, http://bossierpress.com/wp-content/uploads/2018/10/lo-walker-272x300.jpg 272w, http://bossierpress.com/wp-content/uploads/2018/10/lo-walker-768x846.jpg 768w, http://bossierpress.com/wp-content/uploads/2018/10/lo-walker-929x1024.jpg 929w" sizes="(max-width: 1859px) 100vw, 1859px" alt="" title="lo walker"/></a></div>
        <p class="p1"><span class="s1">Bossier City Mayor Lorenz “Lo” Walker will seek office for a record fifth term.</span></p>
<p class="p1"><span class="s1">Mayor Walker confirmed his plans to <em>the Press-Tribune</em> Tuesday afternoon.</span></p>
<p class="p1"><span class="s1">“I didn’t want to say anything to step on the election going on across the river in Shreveport and muddy the water with the Nov. 6 election, but I have announced to my staff that it is my intention to run for election in 2021,” Mayor Walker said.</span></p>
<p class="p1"><span class="s1">He is currently in the middle of his fourth term as mayor of Bossier City. He drew no opposition for the March 25, 2017 election.</span></p>
<p class="p1"><span class="s1">The next city election would be in spring 2021.</span></p>
<p class="p1"><span class="s1">“I enjoy the work. Secondly, with the team we have, I feel we’re doing right by the citizens of Bossier City,” Mayor Walker said as to why he’s running again.</span></p>
<p class="p1"><span class="s1">“We all work so well together and I’m in good health. I think we got good things happening in the city and I want to be a part of it,” he added.</span></p>
<p class="p1"><span class="s1">If elected, Walker would be the longest serving mayor in the history of the City of Bossier City. He is currently tied with the deceased former mayor George Dement, who also served four terms. </span></p>
<p class="p1"><span class="s1">Mayor Walker is already the oldest serving mayor and the oldest elected mayor.</span></p>
<p class="p1"><span class="s1">“I want to be a part of what’s happening here, so long as I enjoy it and I do. I like work and I don’t retire well,” he said. “I don’t think my age is a factor. During my last election, we had a pollster find out that age wasn’t a factor (in who voters would select as mayor).”</span></p>
<p class="p1"><span class="s1">With his history as the director of the Bossier Civic Center, Chief Administrative Officer under former Mayor Dement, and now his service as mayor, Walker has more than 30 years with Bossier City.</span></p>
<p class="p1"><span class="s1">Many of those years have seen tremendous success with steady population growth, the location of riverboat casinos, the building of the CenturyLink Center, the development of the Louisiana Boardwalk, and the redevelopment of central Bossier City as the East Bank District, among several others.</span></p>
<p class="p1"><span class="s1">But Mayor Walker said although his administration has accomplished great things, there is still work to be done that the wants to oversee.</span></p>
<p class="p1"><span class="s1">“The record of what the city has accomplished over the last three decades is outstanding,” he said. “But, for example, we have 22 major public utilities projects — water, sewer, power, and all those important things below ground — that are left to be done.”</span></p>
<p class="p1"><span class="s1">He added that the city’s department heads and their team is one of the reasons for the success. </span></p>
<p class="p1"><span class="s1">“I am only one part, the department heads and their staff deserve the credit,” Mayor Walker said. “Nine years ago, we had 900 staff members and now we’re down to 700. They’ve done a great job doing more with less.”</span></p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags td-pb-padding-side">
                                            </div>

            <div class="td-post-sharing-bottom td-pb-padding-side"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Bossier+City+Mayor+Lo+Walker+to+run+for+a+fifth+term&url=http%3A%2F%2Fbossierpress.com%2Fbossier-city-mayor-lo-walker-to-run-for-a-fifth-term%2F&via=Bossier+Press-Tribune">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/&amp;media=http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg&description=Bossier+City+Mayor+Lo+Walker+to+run+for+a+fifth+term">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Bossier City Mayor Lo Walker to run for a fifth term %0A%0A http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://bossierpress.com/high-school-football-bossier-parish-offensive-stat-leaders-through-week-7/">High school football: Bossier Parish offensive stat leaders through Week 7</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://bossierpress.com/tennis-bossier-tennis-center-pro-killen-to-compete-in-exhibition-wednesday-evening/">Tennis: Bossier Tennis Center pro Killen to compete in exhibition Wednesday evening</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://bossierpress.com/author/sgreen/">Sean Green</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Sean Green"></span><meta itemprop="datePublished" content="2018-10-16T15:57:28+00:00"><meta itemprop="dateModified" content="2018-10-16T15:57:28+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogo.png"></span><meta itemprop="name" content="Bossier Press-Tribune"></span><meta itemprop="headline " content="Bossier City Mayor Lo Walker to run for a fifth term"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://bossierpress.com/wp-content/uploads/2018/10/lo-walker.jpg"><meta itemprop="width" content="1859"><meta itemprop="height" content="2048"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_27_5bc8dfc0d5fd5 = new tdBlock();
block_td_uid_27_5bc8dfc0d5fd5.id = "td_uid_27_5bc8dfc0d5fd5";
block_td_uid_27_5bc8dfc0d5fd5.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_27_5bc8dfc0d5fd5_rand","td_column_number":3,"live_filter_cur_post_id":82283,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_27_5bc8dfc0d5fd5_rand","tdc_css_class_style":"td_uid_27_5bc8dfc0d5fd5_rand_style"}';
block_td_uid_27_5bc8dfc0d5fd5.td_column_number = "3";
block_td_uid_27_5bc8dfc0d5fd5.block_type = "td_block_related_posts";
block_td_uid_27_5bc8dfc0d5fd5.post_count = "3";
block_td_uid_27_5bc8dfc0d5fd5.found_posts = "4750";
block_td_uid_27_5bc8dfc0d5fd5.header_color = "";
block_td_uid_27_5bc8dfc0d5fd5.ajax_pagination_infinite_stop = "";
block_td_uid_27_5bc8dfc0d5fd5.max_num_pages = "1584";
tdBlocksArray.push(block_td_uid_27_5bc8dfc0d5fd5);
</script><div class="td_block_wrap td_block_related_posts td_uid_27_5bc8dfc0d5fd5_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_27_5bc8dfc0d5fd5" ><h4 class="td-related-title"><a id="td_uid_28_5bc8dfc0e0982" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_27_5bc8dfc0d5fd5" href="#">RELATED ARTICLES</a><a id="td_uid_29_5bc8dfc0e09c1" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_27_5bc8dfc0d5fd5" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_27_5bc8dfc0d5fd5 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" class="td-image-wrap" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"><img width="238" height="178" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-238x178.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-238x178.jpg 238w, http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-476x356.jpg 476w" sizes="(-webkit-min-device-pixel-ratio: 2) 476px, (min-resolution: 192dpi) 476px, 238px" alt="" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service">Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" class="td-image-wrap" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"><img width="238" height="124" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 238w, http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 476w" sizes="(-webkit-min-device-pixel-ratio: 2) 476px, (min-resolution: 192dpi) 476px, 238px" alt="" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting">UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" class="td-image-wrap" title="Benton teacher arrested for video voyeruism"><img width="238" height="178" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-238x178.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-238x178.jpg 238w, http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-476x356.jpg 476w" sizes="(-webkit-min-device-pixel-ratio: 2) 476px, (min-resolution: 192dpi) 476px, 238px" alt="" title="Benton teacher arrested for video voyeruism"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" title="Benton teacher arrested for video voyeruism">Benton teacher arrested for video voyeruism</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_27_5bc8dfc0d5fd5" data-td_block_id="td_uid_27_5bc8dfc0d5fd5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_27_5bc8dfc0d5fd5" data-td_block_id="td_uid_27_5bc8dfc0d5fd5"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

<script>
  (function($) {
    $(function() {
      if (!$('#fb-root').size()) {
        $('body').append('<div id="fb-root"></div>');
        (function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) {return;}
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk')); 
      }
    });
    $.post('http://bossierpress.com/wp-admin/admin-ajax.php', {
      action: 'fbc_ping',
      post_id: '82283',
      nonce: 'cb2bcf969f'
    });  
  })(jQuery);
</script>

<a name="comments"></a>



<div id="FatPandaFacebookComments">
  <noscript>
          </noscript>
  <div 
    class="fb-comments" 
    data-colorscheme="light" 
    data-href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/" 
    data-num-posts="10" 
    data-publish_feed="true"
    data-width="600"></div>
</div>



  <div class="navigation">
    <div class="alignleft"></div>
    <div class="alignright"></div>
  </div>

      <div class="commentlist">
      		<div id="comment-4907" class="comment even thread-even depth-1">
			<article id="div-comment-4907" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='CCamp ✝️ 🇺🇸' src='https://pbs.twimg.com/profile_images/1048306348797153280/QekGOxTN_bigger.jpg' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='http://twitter.com/lea11362' rel='external nofollow' class='url'>CCamp ✝️ 🇺🇸</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4907">
							<time datetime="2018-10-17T08:05:16+00:00">
								October 17, 2018 at 8:05 am							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p> Mayor Walker stop going on the cheap with Bossier City water &amp; endangering the health of its citizens… <a href="https://t.co/Klx536nzrD" rel="nofollow">https://t.co/Klx536nzrD</a></p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4902" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-4902" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Louis Digilormo' src='https://graph.facebook.com/2020768724612590/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/2020768724612590' rel='external nofollow' class='url'>Louis Digilormo</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4902">
							<time datetime="2018-10-16T18:10:38+00:00">
								October 16, 2018 at 6:10 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Why is he talking about running so done? BOSSIER needs something new.</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4899" class="comment even thread-even depth-1 parent">
			<article id="div-comment-4899" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Bobby Ballew Jr.' src='https://graph.facebook.com/1173893762706064/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/1173893762706064' rel='external nofollow' class='url'>Bobby Ballew Jr.</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4899">
							<time datetime="2018-10-16T16:36:32+00:00">
								October 16, 2018 at 4:36 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Term limits. Please</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
		<div id="comment-4900" class="comment odd alt depth-2">
			<article id="div-comment-4900" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Mary Catherine Haygood Hammel' src='https://graph.facebook.com/10156825989665078/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/10156825989665078' rel='external nofollow' class='url'>Mary Catherine Haygood Hammel</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4900">
							<time datetime="2018-10-16T16:50:36+00:00">
								October 16, 2018 at 4:50 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bobby Ballew Jr. Yes please</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4901" class="comment even depth-2">
			<article id="div-comment-4901" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Gil Bazo' src='https://graph.facebook.com/247501702260588/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/247501702260588' rel='external nofollow' class='url'>Gil Bazo</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4901">
							<time datetime="2018-10-16T18:05:46+00:00">
								October 16, 2018 at 6:05 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Yes we need term limits!</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4903" class="comment odd alt depth-2">
			<article id="div-comment-4903" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Brian Connell' src='https://graph.facebook.com/10212852350879863/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/10212852350879863' rel='external nofollow' class='url'>Brian Connell</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4903">
							<time datetime="2018-10-16T18:46:47+00:00">
								October 16, 2018 at 6:46 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>There are none in Bossier! 🤫</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4904" class="comment even depth-2">
			<article id="div-comment-4904" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Bobby Ballew Jr.' src='https://graph.facebook.com/1173893762706064/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/1173893762706064' rel='external nofollow' class='url'>Bobby Ballew Jr.</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4904">
							<time datetime="2018-10-16T18:50:53+00:00">
								October 16, 2018 at 6:50 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Brian Connell lol</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
		<div id="comment-4905" class="comment odd alt depth-2">
			<article id="div-comment-4905" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='Mary Catherine Haygood Hammel' src='https://graph.facebook.com/10156825989665078/picture' class='avatar avatar-32 photo avatar-default' height='32' width='32' />						<b class="fn"><a href='https://www.facebook.com/10156825989665078' rel='external nofollow' class='url'>Mary Catherine Haygood Hammel</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://bossierpress.com/bossier-city-mayor-lo-walker-to-run-for-a-fifth-term/#comment-4905">
							<time datetime="2018-10-16T19:36:02+00:00">
								October 16, 2018 at 7:36 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Brian Connell there need to be term limits. This is absurd!</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</div><!-- #comment-## -->
</div><!-- #comment-## -->
    </div> 
  
  <div class="navigation">
    <div class="alignleft"></div>
    <div class="alignright"></div>
  </div>

                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_1 widget widget_sp_image"><h4 class="block-title"><span>Advertisement &#8211; BPT (Wednesday Football Contest)</span></h4><img width="300" height="250" alt="Advertisement &#8211; BPT (Wednesday Football Contest)" class="attachment-300x250" style="max-width: 100%;" src="http://bossierpress.com/wp-content/uploads/2018/09/earFootballContest2.jpg" /></aside><aside class="td_block_template_1 widget widget_sp_image"><h4 class="block-title"><span>Advertisement &#8211; Brooks Heating &#038; Air</span></h4><a href="http://www.brooksheatingandair.com" target="_self" class="widget_sp_image-image-link" title="Advertisement &#8211; Brooks Heating &#038; Air"><img width="301" height="250" alt="Advertisement &#8211; Brooks Heating &#038; Air" class="attachment-301x250" style="max-width: 100%;" src="http://bossierpress.com/wp-content/uploads/2018/10/Brooks-Wb-Ad-1.jpg" /></a></aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Advertisement &#8211; LPA (Gulf Shores Tourism)</span></h4>			<div class="textwidget"><p><script src="https://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=rsb&#038;c=28&#038;pli=25792814&#038;PluID=0&#038;w=300&#038;h=250&#038;ord=[timestamp]"></script></p>
<p><noscript></p>
<p><a href="https://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=brd&#038;FlightID=25792814&#038;Page=&#038;PluID=0&#038;Pos=977581397" target="_blank"><img src="https://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=bsr&#038;FlightID=25792814&#038;Page=&#038;PluID=0&#038;Pos=977581397" border=0 width=300 height=250/></a></p>
<p></noscript></p>
</div>
		</aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Advertisement &#8211; LPA (Pennington Biomedical)</span></h4>			<div class="textwidget"><p><script src="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=rsb&#038;c=28&#038;pli=26162568&#038;PluID=0&#038;w=300&#038;h=250&#038;ord=[timestamp]&#038;ucm=true"></script></p>
<p><noscript></p>
<p><a href="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=brd&#038;FlightID=26162568&#038;Page=&#038;PluID=0&#038;Pos=1530529082" target="_blank"><img src="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=bsr&#038;FlightID=26162568&#038;Page=&#038;PluID=0&#038;Pos=1530529082" border=0 width=300 height=250/></a></p>
<p></noscript></p>
</div>
		</aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Advertisement &#8211; LPA (BBR-LCRT Destinations Louisiana &#8211; St. Landry Parish)</span></h4>			<div class="textwidget"><p><script src="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=rsb&#038;c=28&#038;pli=26108568&#038;PluID=0&#038;w=300&#038;h=250&#038;ord=[timestamp]&#038;ucm=true"></script></p>
<p><noscript></p>
<p><a href="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=brd&#038;FlightID=26108568&#038;Page=&#038;PluID=0&#038;Pos=183311015" target="_blank"><img src="http://bs.serving-sys.com/BurstingPipe/adServer.bs?cn=bsr&#038;FlightID=26108568&#038;Page=&#038;PluID=0&#038;Pos=183311015" border=0 width=300 height=250/></a></p>
<p></noscript></p>
</div>
		</aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Sign Up For the Daily Report</span></h4>			<div class="textwidget"><img class="aligncenter" src="http://bossierpress.com/wp-content/uploads/2018/09/Dailynewsreport.png" alt="BPT Daily Report" />
<!-- Begin MailChimp Signup Form -->
<div id="mc_embed_signup"><form id="mc-embedded-subscribe-form" class="validate" action="http://DavidASpecht.us6.list-manage.com/subscribe/post?u=88b1f59dfc9af52cbbd4f0152&amp;id=92a0264be0" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank"><input id="mce-EMAIL" class="email" name="EMAIL" required="" type="email" value="" placeholder="email address" />
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;"><input tabindex="-1" name="b_88b1f59dfc9af52cbbd4f0152_92a0264be0" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</form></div>
<!--End mc_embed_signup--></div>
		</aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Large Sky -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3723760168360823"
     data-ad-slot="6581690191"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </div>
    </div> <!-- /.td-container -->

    <!-- Instagram -->
    

    <!-- Footer -->
    <div class="td-footer-container td-container">

    <div class="td-pb-row">
        <div class="td-pb-span12">
                    </div>
    </div>

    <div class="td-pb-row">
        <div class="td-pb-span4">
            <div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="http://bossierpress.com/"><img class="td-retina-data" src="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogo.png" data-retina="http://bossierpress.com/wp-content/uploads/2018/09/BPTOnlineLogoRetina.png" alt="" title="" width="" /></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style2"></div></div>        </div>

        <div class="td-pb-span4">
            <div class="td_block_wrap td_block_7 td_uid_31_5bc8dfc0e384b_rand td_block_template_1"  data-td-block-uid="td_uid_31_5bc8dfc0e384b" ><script>var block_td_uid_31_5bc8dfc0e384b = new tdBlock();
block_td_uid_31_5bc8dfc0e384b.id = "td_uid_31_5bc8dfc0e384b";
block_td_uid_31_5bc8dfc0e384b.atts = '{"custom_title":"EVEN MORE NEWS","border_top":"no_border_top","limit":3,"separator":"","custom_url":"","block_template_id":"","color_preset":"","m6_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","class":"td_uid_31_5bc8dfc0e384b_rand","tdc_css_class":"td_uid_31_5bc8dfc0e384b_rand","tdc_css_class_style":"td_uid_31_5bc8dfc0e384b_rand_style"}';
block_td_uid_31_5bc8dfc0e384b.td_column_number = "1";
block_td_uid_31_5bc8dfc0e384b.block_type = "td_block_7";
block_td_uid_31_5bc8dfc0e384b.post_count = "3";
block_td_uid_31_5bc8dfc0e384b.found_posts = "12932";
block_td_uid_31_5bc8dfc0e384b.header_color = "";
block_td_uid_31_5bc8dfc0e384b.ajax_pagination_infinite_stop = "";
block_td_uid_31_5bc8dfc0e384b.max_num_pages = "4311";
tdBlocksArray.push(block_td_uid_31_5bc8dfc0e384b);
</script><h4 class="block-title"><span class="td-pulldown-size">EVEN MORE NEWS</span></h4><div id=td_uid_31_5bc8dfc0e384b class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" class="td-image-wrap" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"><img width="100" height="75" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-100x75.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-100x75.jpg 100w, http://bossierpress.com/wp-content/uploads/2018/10/Day-of-Service-2017-200x150.jpg 200w" sizes="(-webkit-min-device-pixel-ratio: 2) 200px, (min-resolution: 192dpi) 200px, 100px" alt="" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/nearly-600-bossier-schools-volunteers-to-partner-with-united-way-on-day-of-service/" rel="bookmark" title="Nearly 600 Bossier Schools volunteers to partner with United Way on Day of Service">Nearly 600 Bossier Schools volunteers to partner with United Way on...</a></h3>            <div class="meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-18T07:27:22+00:00" >October 18, 2018</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" class="td-image-wrap" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"><img width="100" height="52" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg" srcset="http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 100w, http://bossierpress.com/wp-content/uploads/2016/08/BPSB-Logo.jpg 200w" sizes="(-webkit-min-device-pixel-ratio: 2) 200px, (min-resolution: 192dpi) 200px, 100px" alt="" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/bossier-teachers-reportedly-upset-that-pay-stipend-could-be-reduced/" rel="bookmark" title="UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on at board meeting">UPDATE: Bossier teachers pay stipend to continued unaltered, not voted on...</a></h3>            <div class="meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-17T18:54:58+00:00" >October 17, 2018</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" class="td-image-wrap" title="Benton teacher arrested for video voyeruism"><img width="100" height="75" class="entry-thumb" src="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-100x75.jpg" srcset="http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-100x75.jpg 100w, http://bossierpress.com/wp-content/uploads/2018/10/Aubrey-Norcross-200x150.jpg 200w" sizes="(-webkit-min-device-pixel-ratio: 2) 200px, (min-resolution: 192dpi) 200px, 100px" alt="" title="Benton teacher arrested for video voyeruism"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://bossierpress.com/benton-teacher-arrested-for-video-voyeruism/" rel="bookmark" title="Benton teacher arrested for video voyeruism">Benton teacher arrested for video voyeruism</a></h3>            <div class="meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-17T17:55:56+00:00" >October 17, 2018</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->        </div>

        <div class="td-pb-span4">
            <div class="td_block_wrap td_block_popular_categories td_uid_32_5bc8dfc0e487f_rand widget widget_categories td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_32_5bc8dfc0e487f" ><h4 class="block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4><ul class="td-pb-padding-side"><li><a href="http://bossierpress.com/category/news/">News<span class="td-cat-no">4562</span></a></li><li><a href="http://bossierpress.com/category/sports/">Sports<span class="td-cat-no">3984</span></a></li><li><a href="http://bossierpress.com/category/news/local/">Local<span class="td-cat-no">3373</span></a></li><li><a href="http://bossierpress.com/category/life/">Life<span class="td-cat-no">2951</span></a></li><li><a href="http://bossierpress.com/category/sports/prep/">Prep<span class="td-cat-no">2841</span></a></li><li><a href="http://bossierpress.com/category/life/obituaries/">Obituaries<span class="td-cat-no">2169</span></a></li><li><a href="http://bossierpress.com/category/opinion/">Opinion<span class="td-cat-no">781</span></a></li></ul></div> <!-- ./block -->        </div>
    </div>
</div>

    <!-- Sub Footer -->
        <div class="td-sub-footer-container td-container td-container-border ">
        <div class="td-pb-row">
            <div class="td-pb-span8 td-sub-footer-menu">
                <div class="td-pb-padding-side">
                                    </div>
            </div>

            <div class="td-pb-span4 td-sub-footer-copy">
                <div class="td-pb-padding-side">
                    &copy;                 </div>
            </div>
        </div>
    </div>
    </div><!--close td-outer-container-->
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newsmag by tagDiv.com 2017
        Version: 4.5 (rara)
        Deploy mode: deploy
        
        uid: 5bc8dfc0e5a4f
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/bossierpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://bossierpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.4'></script>
<script type='text/javascript' src='http://bossierpress.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.5'></script>
<script type='text/javascript' src='http://bossierpress.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://bossierpress.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-41070146-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41070146-1');
</script>
<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://bossierpress.com/wp-content/themes/Newsmag/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://bossierpress.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>